Ein bisschen Schwund ist überall

Teile des Blogs waren seit Freitagabend nicht mehr erreichbar. Grund war ein selbstverschuldetes serverseitiges Problem mit der WordPress-Datenbank. Es ist schon am Abend aufgefallen, aber ich hatte keine Lust auf eine Nachtschicht. Da das Backup nicht taufrisch war, fehlen die Posts von knapp zwei Wochen. Ein bisschen was werde ich rekonstruieren können, auch dank G**gle-Cache, aber nicht alles. Und die Moral von der Geschicht': Lösche Datenbanken nicht. Jedenfalls nicht vorschnell. Und checke die Backups zuvor besser doppelt. Dramatisch ist das […]

Wie unschwer zu erken­nen ist, habe ich das alte Blog wie­der akti­viert. Nur der Name ist neu. Die Idee, nach dem Ende des ers­ten Coro­na-Jah­res einen Schnitt zu machen, war prin­zi­pi­ell nicht schlecht. Es hat sich aller­dings gezeigt, dass solch eine Zäsur auch uner­wünsch­te Neben­wir­kun­gen hat.

Trotz einer bis­her noch sehr über­schau­ba­ren Zahl an Bei­trä­gen im neu­en Blog hat­te ich dort schon eini­ge Male ins Archiv ver­linkt. Allein das ist ein Hin­weis, wie wich­tig doch Kon­text in einem Blog ist.

Zudem: Es ist mach­bar, mit einem Plugin wie Sim­ply Sta­tic aus einer Wor­d­Press-Instal­la­ti­on sta­ti­sche HTML-Sei­ten zu machen, die man dann zum Bei­spiel als Archiv ins Netz stel­len kann. So hat­te ich es auch gemacht. Das sieht dann fast so aus wie zuvor.

Aber: Es gibt dort kei­ne Suche, da es ja auch kei­ne Daten­bank mehr gibt. Und in mei­nem Fall fan­den sich nicht alle alten Bei­trä­ge wie­der – vor allem umfang­rei­che­re wur­den nicht ord­nungs­ge­mäß überführt. 

Kann sein, dass es an der schie­ren Grö­ße lag. Es kommt in elf Jah­ren schon eini­ges an Fir­le­fanz und Wider­sinn zusam­men. Bei klei­ne­ren Blogs mag das klag­los funk­tio­nie­ren. Hier hat­te das sta­ti­sche Blog-Archiv eine Grö­ße von 1.8 Gigabyte.

Nun denn, dann mal wei­ter im Text … 😉

Das aller­orts gehyp­te Wor­d­Press-The­me »Gene­ra­te­Press«auch hier seit kur­zem im Ein­satz – ist von Hau­se aus nicht in der Lage, ein You­tube-Video respon­siv ein­zu­bet­ten? Ernst­haft? Das ist das klei­ne Einmaleins.

Statt­des­sen wird den Nut­zern gera­ten, irgend­wel­che Ver­ren­kun­gen und PHP-Pfu­sche­rei­en oder iFrame-Gefum­mel zu veranstalten. 

Das ist doch wohl ein schlech­ter Witz …

Ande­rer­seits: In der Nicht-Kauf-Ver­si­on beherrscht das The­me nicht ein­mal Headerbilder.

Man spürt die Absicht und ist verstimmt.

Fuck »is-style-default«. I want »ali­gn­no­ne« back, damnit!

Eigent­lich soll­ten sich in Wor­d­Press eige­ne Ping­backs mit die­sem Code-Schnip­sel in der functions.php des The­mes unter­drü­cken lassen.

Hat lan­ge funk­tio­niert. Aber hier klappt das nun nicht mehr. 

Mir ist nicht klar, wie­so nicht.

/**
 * Keine eigenen Pingbacks zulassen
 * 
 */
function ah_no_self_ping( &$links ) {
 $home = get_option( 'home' );
 foreach ( $links as $l => $link )
 if ( 0 === strpos( $link, $home ) )
 unset($links[$l]);
}

add_action( 'pre_ping', 'ah_no_self_ping' );